Happeo unavailable
Incident Report for Happeo
Resolved
This incident has been resolved.
Posted Mar 18, 2024 - 09:20 UTC
Monitoring
Happeo is available again,

Apologies for the inconveniences.
Posted Mar 18, 2024 - 09:13 UTC
Investigating
Happeo is currently experiencing availability issues.

Our team is actively working on the issue.

Apologies for the inconveniences.
Posted Mar 18, 2024 - 08:49 UTC
This incident affected: Web Application.