Happeo unavailable
Incident Report for Happeo
Resolved
This incident has been resolved.
Posted Sep 27, 2023 - 11:37 UTC
Monitoring
Service has been restored and we are continuing to closely monitor the situation.
Posted Sep 27, 2023 - 07:57 UTC
Identified
The issue has been identified and our engineers are working on restoring the service.
Posted Sep 27, 2023 - 07:53 UTC
Investigating
We are currently investigating an issue that is impacting Happeo.
Posted Sep 27, 2023 - 07:46 UTC
This incident affected: Web Application.