Appengine Outage - Happeo unaccessible
Incident Report for Happeo
Postmortem

Start time: 2019-10-08 12:10

Got notified: 2019-10-08 12:15

Resolution time: 2019-10-08 12:51

Problem:

Happeo was inaccessible from web and mobile. All APIs were down.

Affected:

All customers, all users.

Root cause:

Google Appengine and Cloud Functions were down in Europe West 1. GCP Appengine in EU West 1 is our main computing platform and if it is down, our application is down.

We don’t have backup servers in other regions because, in Appengine Standard, it is not possible.

Actions taken:

Posted Oct 18, 2019 - 06:15 UTC

Resolved
Google Appengine and Cloud Functions were down in Europe West 1. GCP Appengine in EU West 1 is our main computing platform and when it crashed in Google Cloud Platform, Happeo was inaccessible. We just needed to wait for Google to fixe the issue.
Posted Oct 08, 2019 - 09:10 UTC