Bookmarks feature is not available
Incident Report for Happeo
Resolved
The issue with the bookmarks has now been resolved.
Posted Jun 26, 2020 - 22:04 UTC
Identified
We have identified the issue with bookmarks and are working on a fix.
Posted Jun 26, 2020 - 21:06 UTC
This incident affected: Bookmarks.