Verification is currently underway for the maintenance items.
Posted Nov 23, 2025 - 08:59 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 23, 2025 - 08:00 UTC
Scheduled
We are performing database maintenance on Happeo on Sunday, 23 November 2025, from 08:00 to 11:00 (UTC). During the maintenance period, Happeo may be unavailable for some time. We regret the inconvenience caused.
Posted Nov 18, 2025 - 14:25 UTC
This scheduled maintenance affected: Notifications (Email Notifications, Push Notifications, Notifications) and Web Application, Mobile application, Launcher, Bookmarks, Google Workspace Integration, User Management, Login.